Pythonと!

プログラミングド素人の勉強日記です。

ValueError: Mime type rendering requires nbformat>=4.2.0 but it is not installed

jupyterでこれをやろうとしたところ、

import plotly.express as px
%matplotlib inline

gapminder = px.data.gapminder()
px.scatter(gapminder, x='gdpPercap', y='lifeExp', log_x=True, hover_name='country')

以下のようなエラーが出ました。

ValueError: Mime type rendering requires nbformat>=4.2.0 but it is not installed

・対応策

$ pip install nbformat
$ pip install --upgrade nbformat
# そしてカーネル再起動